hylom'sWeblog

- hylom's blog
| about hylom / hylom.net | old contents | login

KiCAD 4系からKiCAD 5系にアップデートするときにGitHub経由でフットプリントライブラリを参照するようにしているとハマる

posted on 2019/07/09 02:33:31

 KiCAD 4系からKiCAD 5系にアップデートした場合、設定等は引き継がれることになるのだが、その際にGitHub経由で公式のフットプリントライブラリを参照しているようにしているとハマる。

 公式フットプリントライブラリはバージョン5以降用のものが4以前のものと違うリポジトリで提供されているため。自分の環境では、4以前のライブラリを使うような設定だとフットプリントの割り当て時にピン数でのフィルタがうまく動作しなかった。